Opened 4 years ago

Closed 4 years ago

#1197 closed defect (fixed)

NVDA mostly reports incorrect information when using the Report Line command

Reported by: elliott94 Owned by:
Priority: minor Milestone:
Component: Speech Version: master
Keywords: Cc:
Operating system: Blocked by:
Blocking:
Changes document entry (for developers):

Description

When using the Report Line command (NVDA+up arrow), instead of simply reading the line which the curser is situated, with the latest couple of snapshots (I'm currently using 3929), NVDA will instead read some of the information on that line, but will then randomly read information from different lines of the window, or in some cases another open window that doesn't have focus.

Change History (5)

comment:1 follow-up: Changed 4 years ago by jteh

It is highly unlikely that NVDA+upArrow would do this. I'll wager you are bumping the mouse just slightly. You can turn off mouse tracking with NVDA+m to test this theory.

comment:2 in reply to: ↑ 1 Changed 4 years ago by elliott94

Replying to jteh:

It is highly unlikely that NVDA+upArrow would do this. I'll wager you are bumping the mouse just slightly. You can turn off mouse tracking with NVDA+m to test this theory.

I'm afraid this isn't the case. As well as this, I'm also encountering the same sort of behaviour when using the Report Current Navigator Object pressed twice quickly to spell it out.
Below, I've pasted a section of my log which shows this behaviour. First you'll see the link that I was reading, then the result of when I used the Report Current Line Command.

Input: kb(desktop):h
IO - speech.speakText (12:09:53):
Speaking u'Smugglers3.Need some help. link heading level 3'
IO - inputCore.InputManager.executeGesture (12:09:54):
Input: kb(desktop):nvda+uparrow
IO - speech.speakText (12:09:54):
Speaking u'heading level 3 link Smugglers3.Need some help.'
IO - inputCore.InputManager.executeGesture (12:09:54):
Input: kb(desktop):nvda+uparrow
IO - speech._speakSpellingGen (12:09:54):
Speaking character u'S'
DEBUG - queueHandler.registerGeneratorObject (12:09:54):
Adding generator 18
IO - speech._speakSpellingGen (12:09:54):
Speaking character u'm'
IO - speech._speakSpellingGen (12:09:54):
Speaking character u'u'
IO - speech._speakSpellingGen (12:09:54):
Speaking character u'g'
IO - speech._speakSpellingGen (12:09:54):
Speaking character u'g'
IO - speech._speakSpellingGen (12:09:54):
Speaking character u'l'
IO - speech._speakSpellingGen (12:09:55):
Speaking character u'e'
IO - speech._speakSpellingGen (12:09:55):
Speaking character u'r'
IO - speech._speakSpellingGen (12:09:55):
Speaking character u's'
IO - speech._speakSpellingGen (12:09:55):
Speaking character u'3'
IO - speech._speakSpellingGen (12:09:55):
Speaking character u'space'
IO - speech._speakSpellingGen (12:09:55):
Speaking character u'dot'
IO - speech._speakSpellingGen (12:09:55):
Speaking character u'C'
IO - speech._speakSpellingGen (12:09:55):
Speaking character u'N'
IO - speech._speakSpellingGen (12:09:55):
Speaking character u'e'
IO - speech._speakSpellingGen (12:09:55):
Speaking character u'o'
IO - speech._speakSpellingGen (12:09:55):
Speaking character u'e'
IO - speech._speakSpellingGen (12:09:55):
Speaking character u'o'
IO - speech._speakSpellingGen (12:09:56):
Speaking character u'l'
IO - speech._speakSpellingGen (12:09:56):
Speaking character u'd'
IO - speech._speakSpellingGen (12:09:56):
Speaking character u'underline'
IO - speech._speakSpellingGen (12:09:56):
Speaking character u'space'
IO - speech._speakSpellingGen (12:09:56):
Speaking character u'space'
IO - speech._speakSpellingGen (12:09:56):
Speaking character u'G'
IO - speech._speakSpellingGen (12:09:56):
Speaking character u'and'
IO - speech._speakSpellingGen (12:09:56):
Speaking character u's'
IO - speech._speakSpellingGen (12:09:56):
Speaking character u'o'
IO - speech._speakSpellingGen (12:09:56):
Speaking character u'space'
IO - speech._speakSpellingGen (12:09:56):
Speaking character u'o'
IO - speech._speakSpellingGen (12:09:57):
Speaking character u'l'
IO - speech._speakSpellingGen (12:09:57):
Speaking character u'D'
IO - speech._speakSpellingGen (12:09:57):
Speaking character u'm'
IO - speech._speakSpellingGen (12:09:57):
Speaking character u'e'
IO - speech._speakSpellingGen (12:09:57):
Speaking character u'd'
IO - speech._speakSpellingGen (12:09:57):
Speaking character u'c'
IO - speech._speakSpellingGen (12:09:57):
Speaking character u'space'
IO - speech._speakSpellingGen (12:09:57):
Speaking character u'dash'
IO - speech._speakSpellingGen (12:09:57):
Speaking character u'u'
IO - speech._speakSpellingGen (12:09:57):
Speaking character u'h'
IO - speech._speakSpellingGen (12:09:57):
Speaking character u'2'
IO - speech._speakSpellingGen (12:09:57):
Speaking character u'p'
IO - speech._speakSpellingGen (12:09:58):
Speaking character u'e'
IO - speech._speakSpellingGen (12:09:58):
Speaking character u'0'
IO - speech._speakSpellingGen (12:09:58):
Speaking character u'space'
IO - speech._speakSpellingGen (12:09:58):
Speaking character u'1'
IO - speech._speakSpellingGen (12:09:58):
Speaking character u'dash'
IO - speech._speakSpellingGen (12:09:58):
Speaking character u'l'
IO - speech._speakSpellingGen (12:09:58):
Speaking character u'0'
IO - speech._speakSpellingGen (12:09:58):
Speaking character u'space'
IO - speech._speakSpellingGen (12:09:58):
Speaking character u'p'
IO - speech._speakSpellingGen (12:09:59):
Speaking character u'dot'
IO - speech._speakSpellingGen (12:09:59):
Speaking character u'dash'
IO - speech._speakSpellingGen (12:09:59):
Speaking character u'W'
DEBUG - queueHandler.pumpAll (12:09:59):
generator 18 finished
IO - speech._speakSpellingGen (12:09:59):
Speaking character u'F'
IO - speech._speakSpellingGen (12:09:59):
Speaking character u'e'
IO - speech._speakSpellingGen (12:09:59):
Speaking character u'R'
IO - speech._speakSpellingGen (12:09:59):
Speaking character u'space'
IO - speech._speakSpellingGen (12:10:00):
Speaking character u'A'
IO - speech._speakSpellingGen (12:10:00):
Speaking character u'N'
IO - speech._speakSpellingGen (12:10:00):
Speaking character u'Y'
IO - speech._speakSpellingGen (12:10:00):
Speaking character u'o'
DEBUG - queueHandler.pumpAll (12:10:00):
generator 16 finished
IO - speech._speakSpellingGen (12:10:00):
Speaking character u'space'
IO - speech._speakSpellingGen (12:10:00):
Speaking character u'S'
IO - speech._speakSpellingGen (12:10:00):
Speaking character u'p'
IO - speech._speakSpellingGen (12:10:00):
Speaking character u'e'
IO - speech._speakSpellingGen (12:10:00):
Speaking character u'a'
IO - speech._speakSpellingGen (12:10:00):
Speaking character u'k'
IO - speech._speakSpellingGen (12:10:00):
Speaking character u'space'
IO - speech._speakSpellingGen (12:10:01):
Speaking character u'A'
IO - speech._speakSpellingGen (12:10:01):
Speaking character u't'
IO - speech._speakSpellingGen (12:10:01):
Speaking character u'm'
IO - speech._speakSpellingGen (12:10:01):
Speaking character u'a'
IO - speech._speakSpellingGen (12:10:01):
Speaking character u'e'
IO - speech._speakSpellingGen (12:10:01):
Speaking character u'r'
IO - speech._speakSpellingGen (12:10:01):
Speaking character u'l'
IO - speech._speakSpellingGen (12:10:01):
Speaking character u'k'
IO - speech._speakSpellingGen (12:10:01):
Speaking character u'i'
IO - speech._speakSpellingGen (12:10:01):
Speaking character u'c'
IO - speech._speakSpellingGen (12:10:01):
Speaking character u'space'
IO - speech._speakSpellingGen (12:10:01):
Speaking character u'a'
IO - speech._speakSpellingGen (12:10:01):
Speaking character u'a'
IO - speech._speakSpellingGen (12:10:02):
Speaking character u'n'
IO - speech._speakSpellingGen (12:10:02):
Speaking character u'b'
IO - speech._speakSpellingGen (12:10:02):
Speaking character u'o'
IO - speech._speakSpellingGen (12:10:02):
Speaking character u'o'
IO - speech._speakSpellingGen (12:10:02):
Speaking character u'space'
IO - speech._speakSpellingGen (12:10:02):
Speaking character u'u'
IO - speech._speakSpellingGen (12:10:02):
Speaking character u't'
IO - speech._speakSpellingGen (12:10:02):
Speaking character u'left paren'
IO - speech._speakSpellingGen (12:10:02):
Speaking character u'space'
IO - speech._speakSpellingGen (12:10:02):
Speaking character u'O'
IO - speech._speakSpellingGen (12:10:03):
Speaking character u'r'
IO - speech._speakSpellingGen (12:10:03):
Speaking character u'g'
IO - speech._speakSpellingGen (12:10:03):
Speaking character u'i'
IO - speech._speakSpellingGen (12:10:03):
Speaking character u'a'
IO - speech._speakSpellingGen (12:10:03):
Speaking character u'm'
IO - speech._speakSpellingGen (12:10:03):
Speaking character u'g'
IO - speech._speakSpellingGen (12:10:03):
Speaking character u'i'
IO - speech._speakSpellingGen (12:10:03):
Speaking character u'e'
IO - speech._speakSpellingGen (12:10:03):
Speaking character u's'
IO - speech._speakSpellingGen (12:10:03):
Speaking character u'n'
IO - speech._speakSpellingGen (12:10:03):
Speaking character u'a'
IO - speech._speakSpellingGen (12:10:03):
Speaking character u'comma'
IO - speech._speakSpellingGen (12:10:04):
Speaking character u'l'
IO - speech._speakSpellingGen (12:10:04):
Speaking character u'space'
IO - speech._speakSpellingGen (12:10:04):
Speaking character u'space'
IO - speech._speakSpellingGen (12:10:04):
Speaking character u'p'
IO - speech._speakSpellingGen (12:10:04):
Speaking character u'm'
IO - speech._speakSpellingGen (12:10:04):
Speaking character u'o'
IO - speech._speakSpellingGen (12:10:04):
Speaking character u'i'
IO - speech._speakSpellingGen (12:10:04):
Speaking character u's'
IO - speech._speakSpellingGen (12:10:04):
Speaking character u'x'
IO - speech._speakSpellingGen (12:10:04):
Speaking character u't'
IO - speech._speakSpellingGen (12:10:05):
Speaking character u'right paren'
IO - speech._speakSpellingGen (12:10:05):
Speaking character u'space'
IO - speech._speakSpellingGen (12:10:05):
Speaking character u'y'
IO - speech._speakSpellingGen (12:10:05):
Speaking character u'dot'
IO - speech._speakSpellingGen (12:10:05):
Speaking character u'm'
IO - speech._speakSpellingGen (12:10:05):
Speaking character u'o'
IO - speech._speakSpellingGen (12:10:05):
Speaking character u'p'
IO - speech._speakSpellingGen (12:10:05):
Speaking character u'u'
IO - speech._speakSpellingGen (12:10:05):
Speaking character u'3'
IO - speech._speakSpellingGen (12:10:05):
Speaking character u'r'
IO - speech._speakSpellingGen (12:10:06):
Speaking character u'space'
DEBUG - queueHandler.pumpAll (12:10:06):
generator 17 finished
IO - speech._speakSpellingGen (12:10:06):
Speaking character u'h'
IO - speech._speakSpellingGen (12:10:06):
Speaking character u'i'
IO - speech._speakSpellingGen (12:10:06):
Speaking character u'dash'
IO - speech._speakSpellingGen (12:10:06):
Speaking character u's'
IO - speech._speakSpellingGen (12:10:06):
Speaking character u'c'
IO - speech._speakSpellingGen (12:10:06):
Speaking character u'o'
IO - speech._speakSpellingGen (12:10:06):
Speaking character u'r'
IO - speech._speakSpellingGen (12:10:06):
Speaking character u'e'
IO - speech._speakSpellingGen (12:10:07):
Speaking character u's'
IO - speech._speakSpellingGen (12:10:07):
Speaking character u'space'
IO - speech._speakSpellingGen (12:10:07):
Speaking character u'a'
IO - speech._speakSpellingGen (12:10:07):
Speaking character u'n'
IO - speech._speakSpellingGen (12:10:07):
Speaking character u'd'
IO - speech._speakSpellingGen (12:10:07):
Speaking character u'space'
IO - speech._speakSpellingGen (12:10:07):
Speaking character u'c'
IO - speech._speakSpellingGen (12:10:07):
Speaking character u'h'
IO - speech._speakSpellingGen (12:10:07):
Speaking character u'a'
IO - speech._speakSpellingGen (12:10:07):
Speaking character u'l'
IO - speech._speakSpellingGen (12:10:08):
Speaking character u'l'
IO - speech._speakSpellingGen (12:10:08):
Speaking character u'e'
IO - speech._speakSpellingGen (12:10:08):
Speaking character u'n'
IO - speech._speakSpellingGen (12:10:08):
Speaking character u'g'
IO - speech._speakSpellingGen (12:10:08):
Speaking character u'e'
IO - speech._speakSpellingGen (12:10:08):
Speaking character u'space'
IO - speech._speakSpellingGen (12:10:08):
Speaking character u'o'
IO - speech._speakSpellingGen (12:10:08):
Speaking character u't'
IO - speech._speakSpellingGen (12:10:08):
Speaking character u'h'
IO - speech._speakSpellingGen (12:10:08):
Speaking character u'e'
IO - speech._speakSpellingGen (12:10:08):
Speaking character u'r'
IO - speech._speakSpellingGen (12:10:08):
Speaking character u's'
DEBUG - queueHandler.pumpAll (12:10:08):
generator 8 finished
IO - inputCore.InputManager.executeGesture (12:10:26):
Input: kb(desktop):nvda+n
DEBUG - appModuleHandler.getKeyMapFileName (12:10:26):
Found keymap file for _default at .\appModules\_default_desktop.kbd
DEBUG - appModuleHandler.AppModule.loadKeyMap (12:10:26):
added 80 bindings to appModule <nvda (appName nvda, process ID 3776) at address 6f18770> from file .\appModules\_default_desktop.kbd
DEBUG - appModuleHandler.getKeyMapFileName (12:10:26):
No keymapFile for nvda
IO - speech.speakText (12:10:26):
Speaking u'unknown'
IO - speech.speakText (12:10:26):
Speaking u'NVDA menu'
IO - inputCore.InputManager.executeGesture (12:10:27):
Input: kb(desktop):downarrow
IO - speech.speakText (12:10:27):
Speaking u'Preferences subMenu p'
IO - inputCore.InputManager.executeGesture (12:10:27):
Input: kb(desktop):downarrow
IO - speech.speakText (12:10:27):
Speaking u'Tools subMenu t'
IO - inputCore.InputManager.executeGesture (12:10:28):
Input: kb(desktop):rightarrow
IO - speech.speakText (12:10:28):
Speaking u'View log v'
IO - inputCore.InputManager.executeGesture (12:10:28):
Input: kb(desktop):enter

comment:3 Changed 4 years ago by briang1

Hi, I cannot see this in XP here. Is this specific to a browser or website.

Although there is no indication of mouse mangling in the log, I'd point out that some laptops with joysticks in the keys and pads can create havoc at times.

If you use nvda 5 three times what ends up in the clipboard?

I am using snap main 3935 here.

comment:4 follow-up: Changed 4 years ago by jteh

Are you talking specifically about the information which is read when you press either of these keys twice to spell the info? If so, this is a duplicate of #1188, which is fixed in changeset:7a72bd3698e2cf95da181b0dbd76d9ad8253cf9b. This bug only relates to spelling.

comment:5 in reply to: ↑ 4 Changed 4 years ago by elliott94

  • Component changed from Virtual buffers to Speech
  • Operating system Windows 7 deleted
  • Resolution set to fixed
  • Status changed from new to closed

Replying to jteh:

Are you talking specifically about the information which is read when you press either of these keys twice to spell the info? If so, this is a duplicate of #1188, which is fixed in changeset:7a72bd3698e2cf95da181b0dbd76d9ad8253cf9b. This bug only relates to spelling.

In this case, this bug is in deed related to #1188. I'll update now, and if the problem still persists, I'll re-open the ticket.

Note: See TracTickets for help on using tickets.