Opened 4 years ago

Closed 4 years ago

#1263 closed defect (fixed)

Nasty noise as nvda shuts down

Reported by: briang1 Owned by: jteh
Priority: minor Milestone: 2011.1
Component: Core Version: master
Keywords: regression Cc:
Operating system: Blocked by:
Blocking:
Changes document entry (for developers):

Description

This seems to have ocurred somwhere between snap 954 and 970.

How to produce the sound.
All you need to do is run some software, like IE or Outlook Express for a while, normally about 10 minutes on my machines, then do an nvda restart or quit in any way and you will hear it after the falling tones. Many people who have heard this on the freelist list suggest its the error sound truncated and played multiple times, lasting around 2 or so seconds. There are no obvious signs of an error in the log file. However a mp3 of it is added if the ticket system will allow me to.


Other comments.#

I know you prefer problems to be in seperate tickets, but I feel that alied to this strange effect is a tendency to crash applications like IE Outlook expres amd Skype. Hard to quantify of course but might be worth bearing in mind.

Attachments (1)

raspberry in nvda.mp3 (42.5 KB) - added by briang1 4 years ago.
sound file

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by briang1

sound file

comment:1 Changed 4 years ago by jteh

  • Keywords regression added
  • Milestone set to 2011.1
  • Operating system Windows XP deleted

This is definitely the error sound. Unfortunately, I haven't been able to work out what is causing it either. As you say, there is no useful log output.

Technical: I suspect there is a problem in a destructor somewhere, but I can't work out where and how it got introduced recently.

comment:2 Changed 4 years ago by jteh

Regression caused by changeset:10d7d8abb2a3b79ac62838efdc2583b50800bbcd (introduction of global plugins). I have no idea how the global plugins code is causing this. It only seems to happen if you've been using MSHTML controls.

comment:3 Changed 4 years ago by jteh

  • Owner set to jteh
  • Status changed from new to accepted

Actually, this isn't specific to MSHTML controls at all.

Technical: It looks like AppModules for closed applications now take a lot longer to be garbage collected than they did previously. From what I can tell, this seems to be due to the new event chaining code; the frame objects for eventHandler.EventExecuter.gen() don't seem to be cleaned up straight away. Anyway, if they don't get garbage collected before NVDA exits, they try to call NVDAHelper.localLib.destroyConnection(), but NVDAHelper has already been terminated at that point, so it fails. I assume part of the logging framework has already been garbage collected as well, hence the weird logging behaviour.

Anyway, I think we need an AppModule.terminate() function and code to cleanup app modules on exit, similar to what we do for tree interceptors and global plugins.

comment:4 Changed 4 years ago by jteh

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.