Opened 4 years ago

Closed 3 years ago

#1528 closed defect (fixed)

Opening Sql Server Management Studio (SSMS) 2008 Express Edition causes NVDA to stop responding

Reported by: ianr Owned by:
Priority: minor Milestone: 2011.3
Component: Core Version: 2011.1.1
Keywords: freeze Cc:
Operating system: Windows 7 Blocked by: #1408
Blocking:
Changes document entry (for developers):

Description

When I open SSMS while NVDA is running NVDA stops speaking.
My current workaround is to get ready to open SSMS, close NVDA, then open SSMS and restart NVDA.

I will attach a log file.

Attachments (2)

nvda.log (231.3 KB) - added by ianr 4 years ago.
without braille display nvda.log (1.5 KB) - added by ianr 4 years ago.
This log is from a fresh nvda start with my braille display detached to show that my braille display is not causing the freeze.

Download all attachments as: .zip

Change History (10)

Changed 4 years ago by ianr

Changed 4 years ago by ianr

This log is from a fresh nvda start with my braille display detached to show that my braille display is not causing the freeze.

comment:1 Changed 4 years ago by jteh

Surprise surprise. Another freeze in isUIAWindow.

comment:2 Changed 4 years ago by jteh

  • Blocked by 1408 added
  • Keywords freeze added

Is this app free or paid? If paid, we're unfortunately not going to be able to debug this specific case.

comment:3 Changed 4 years ago by ianr

This application is free and can be downloaded at this link:
http://www.microsoft.com/downloads/en/details.aspx?FamilyID=08e52ac2-1d62-45f6-9a4a-4b76a8564a2b
Ticket #912 also refers to this application.

comment:4 Changed 4 years ago by ianr

This differs a little from ticket 1408 as in 1408 nvda is affected because the other application is not responding. In this application the application continues to respond normally, but nvda stops responding.

If these are problems with UI Automation and you have reported them to Microsoft is there any way users can show their support for Microsoft to fix UIA? ie. a Microsoft ticket we can comment on or anything?

comment:5 Changed 4 years ago by jteh

The only reason I know of that isUIAWindow might freeze is if a window stops responding. Note that it doesn't have to be the whole application; it could just be one window. Sometimes, applications seem to create unresponsive windows and then hide them, even though they really shouldn't. I'd have to debug further to know. If this is the case, technically, it's a bug in the application, though the function should at least time out or something. Anyway, it is related to #1408, even if the symptoms seem different.

We haven't formally reported these issues to Microsoft because they're very difficult to reproduce outside of very specific circumstances (including running a screen reader) and I suspect Microsoft aren't particularly interested in testing with NVDA. Also, we've been told on other occasions that the chances of getting an accessibility related fix into an earlier version of software is highly unlikely and it would cost us money just to file the issue.

comment:6 Changed 3 years ago by jteh

Can you please confirm whether this is fixed by changeset:7366dee2aab38f1adb7f63b05bd8a1cd3e9ea855? (A snapshot for this should be available in about 23 hours.)

comment:7 Changed 3 years ago by ianr

I tested with snapshot 4634 and the problem is fixed. Thanks very much!

comment:8 Changed 3 years ago by jteh

  • Milestone set to 2011.3
  • Resolution set to fixed
  • Status changed from new to closed

See comment:7.

Note: See TracTickets for help on using tickets.