Opened 2 years ago

Closed 21 months ago

#2168 closed defect (duplicate)

NVDA not rendering all content in virtual buffers in Firefox

Reported by: KevanGC Owned by:
Priority: minor Milestone:
Component: Browse mode Version: 2011.3
Keywords: Cc:
Operating system: Windows 7 Blocked by:
Blocking:
Changes document entry (for developers):

Description

NVDA 2011.3, with Firefox 11.

STR: Go to audible.com and search for anything.

Expected: NVDA should read the book search results after the filter options.
Actual: The virtual buffer contains no book search results, but they are shown. Switching to focus mode and tabbing on the last filter does cause NVDA to read them, although it's difficult to navigate that way.

Luckily I still have the setup file to Firefox 3.6, so I was able to switch back to that and things work nicely. I'm not sure what version of Firefox this problem began in, but it would be amazing if you could get it fixed if it's an NVDA issue. Audible probably isn't the only site where NVDA won't read all the content, I just got Firefox 11 today and haven't found any other sites with the problem, but if it happens on Audible, it can happen anywhere else.

Change History (3)

comment:1 Changed 2 years ago by briang1

I cannot see this effect using XP and ff11. However It does seem to put the cursor position on the bottom of the list rather than the top for some reason after a search. Of course having no sight and not knowing the site, it could be that stuff is missing but I certainly get a list of items that are connected to my search with the usual listen and buy stuff on links.
I also tried ff3.68 and IE8 and they seem to act more or less the same. I tried it with the rc1 and the 2011.3 versions of nvda and the latest snap as well.

comment:2 Changed 2 years ago by jteh

I suspect this is a duplicate of #2059. Please try again with Firefox maximised if it isn't already. Failing that, please try with Firefox 12pre.

comment:3 Changed 21 months ago by jteh

  • Resolution set to duplicate
  • Status changed from new to closed

Closing as a duplicate of #2059 (fixed in Firefox 12). If you can still reproduce this with recent Firefox versions, please reopen.

Note: See TracTickets for help on using tickets.