Opened 3 years ago

Closed 3 months ago

Last modified 3 months ago

#2209 closed enhancement (fixed)

Default shortcut key to start NVDA does not work on Polish keyboards

Reported by: pitermach Owned by: jteh
Priority: minor Milestone: 2014.3
Component: Localisation Version: master
Keywords: Cc: grzezlo@o2.pl
Operating system: Blocked by:
Blocking:
Changes document entry (for developers):

Description

So, I’m really liking this new installer, and since it’s now in development, I’d like to make a small request.
The default shortcut key of NVDA’s desktop icon is CTRL+Alt+N, which interferes with the Polish ń letter.
To remove the issue, the Polish user guide has instructions on how to remove the shortcut key from the icon after installation.
Could the installer prompt for what key to use, rather than using the default? Window-Eyes does this and even though its shortcut doesn’t conflict with anything, the function exists if needed.

Change History (30)

comment:1 follow-up: Changed 3 years ago by jteh

If we implemented it, I'd consider customising the shortcut key an advanced option.

What about using a different key depending on the detected locale? That way, you can just document the required key in the User Guide. Explorer only allows use of control+alt shortcuts. Are there any that don't conflict?

comment:2 in reply to: ↑ 1 Changed 3 years ago by pitermach

Well, a, s, e, z, x, c, l, o, and n are taken.
I don't really see what's so advanced about a simple box though, and changing it based on Windows language would take more coding. People may have different preferences as to what key is comfortable for them. For example I have mine set to Q just because I thought of it, while someone may just go for V since it's the second letter in "NVDA".
Replying to jteh:

If we implemented it, I'd consider customising the shortcut key an advanced option.

What about using a different key depending on the detected locale? That way, you can just document the required key in the User Guide. Explorer only allows use of control+alt shortcuts. Are there any that don't conflict?

comment:3 follow-up: Changed 3 years ago by jteh

True, but it makes documentation more complicated. Also, a user who wants to customise it can equally do so using the properties dialog on the shortcut. The important point is that you originally filed this because control+alt+n doesn't work for your language, so a better default is required for your language.

comment:4 in reply to: ↑ 3 Changed 3 years ago by pitermach

Yep, I suppose that's true. In that case I think we should go for V since it still makes some sense and I'm not aware of any keyboard layouts having an accent under V, Polish or otherwise.
Replying to jteh:

True, but it makes documentation more complicated. Also, a user who wants to customise it can equally do so using the properties dialog on the shortcut. The important point is that you originally filed this because control+alt+n doesn't work for your language, so a better default is required for your language.

comment:5 Changed 3 years ago by jteh

  • Component changed from Installer to Localisation
  • Milestone set to 2012.2
  • Owner set to pvagner
  • Summary changed from NVDA's installer does not allow to change shortcut key of desktop icon to Default shortcut key to start NVDA does not work on Polish keyboards

The easiest solution is probably to make the shortcut a translatable string using gettext and clearly describe it in a translator comment. Does anyone object to this idea?

comment:6 follow-up: Changed 3 years ago by orcauser

does altGR+n give you the letter that you get when pressint ctrl+alt+n?

comment:7 Changed 3 years ago by jteh

It'd be good to get some definitive direction on this. @pitermach, can you please reply to comment:6?

Mesar, is there any reason against using gettext for this (as per comment:5)?

comment:8 in reply to: ↑ 6 Changed 3 years ago by pitermach

Edit: initially I said no.. it actually does, just never heard the term altGR before which threw me.
So yeah, it does give me the character, though, it too switches to starting NVDA if the desktop icon gets installed.
Also for shortcut keys, control shift also seems to be usable, though I don't think we should use that since it's very possible it might conflict with a command in an application.
Replying to orcauser:

does altGR+n give you the letter that you get when pressint ctrl+alt+n?

Last edited 3 years ago by pitermach (previous) (diff)

comment:9 follow-up: Changed 3 years ago by pvagner

I think jamie's idea proposed in comment 5 is the most friendly for me as well.
In slovak ctrl+alt+n clashes with a right brace, ctrl+alt+v clashes with at '@' sign so it's even worse.
Of course I did not see this as an issue and it appears other slovak users as well because right brace is not frequently used in slovak. Slovak programmers and other techie's tent to use english keyboard when they require these symbols not comfortably placed on a slovak keyboard.
I am a bit afraid to use gettext for this but yeaah technically it's definatelly possible.

comment:10 in reply to: ↑ 9 ; follow-up: Changed 3 years ago by jteh

Replying to pvagner:

In slovak ctrl+alt+n clashes with a right brace, ctrl+alt+v clashes with at '@' sign so it's even worse.
Of course I did not see this as an issue and it appears other slovak users as well because right brace is not frequently used in slovak.

Given this, would you localise the key for Slovak or not? If so, any idea what key you would use?

comment:11 in reply to: ↑ 10 Changed 3 years ago by pvagner

Replying to jteh:

Given this, would you localise the key for Slovak or not? If so, any idea what key you would use?

I would probably keep it ctrl+alt+n because people aare used to it. Beginner computer users even don't know what a right brace is. But if I were forced to change it it'll change to ctrl+alt+a .
ctrl+alt+d is also occupied on a slovak keyboard. It prints the letter d with inverted acute. I even don't know how this letter can be used. definatelly this is not slovak letter.

comment:12 follow-up: Changed 3 years ago by pitermach

On a Polish keyboard, oddly enough all the symbols are just like on an English one, with the accents placed under control alt. This is actually called the programmers layout and it's what windows defaults to. An alternative layout has the accents where normally the brackets and other punctuation was, with z and y reversed making qwerty into qwertz. I don't know anyone who uses it though, most people just get confused when they accidentally switch with alt shift.
That half off topic ramble aside, it does sound like this would be a workable idea since everyone has a different idea for a non-conflicting NVDA key. This will work as long as you don't detect it by windows language, though, since I personally have a US windows here, the only thing that's set to polish is my current country and the keyboard layout.

comment:13 Changed 3 years ago by orcauser

My only objection is as follows:
If the nvda shortcut key is translatable then the way to start nvda is not always the same.
As a user i want to walk up to any machine, and start nvda whatever language.
If it happens to clash with my keyboard, then i should change it, but it is more likely that i will remember the correct keystroke because the change was deliberate.
I hope my reasoning is clear.
Thanks. Mesar

comment:14 follow-up: Changed 3 years ago by orcauser

sorry and another thing, when a user switches nvda interface language, then the shortcut key for starting nvda might change on them.

  1. is that desired?
  2. can we remap the nvda key on the fly, as by the sinario above?

comment:15 in reply to: ↑ 14 Changed 3 years ago by jteh

Replying to orcauser:

If the nvda shortcut key is translatable then the way to start nvda is not always the same.

That's true. However, some other keyboard commands will change as well depending on the locale, so this isn't a new situation. I'll grant starting NVDA is a pretty fundamental case though. This will of course be documented in the language specific User Guide.

If it happens to clash with my keyboard, then i should change it, but it is more likely that i will remember the correct keystroke because the change was deliberate.

You might not have been the person that installed NVDA, though; e.g. public access system.

Replying to orcauser:

sorry and another thing, when a user switches nvda interface language, then the shortcut key for starting nvda might change on them.

Actually, it won't; see below.

  1. is that desired?

Maybe. However, there have always been some strings that are determined by the language used at install time, including all of the shortcut names in the Start menu. This would be no different.

  1. can we remap the nvda key on the fly, as by the sinario above?

No. This isn't possible. The shortcut is a system wide item, whereas the NVDA locale is a user setting.

I'm happy to say wontfix if people decide this isn't ideal. I was just trying to provide a solution to the initial problem.

comment:16 in reply to: ↑ 12 Changed 2 years ago by jteh

  • Resolution set to wontfix
  • Status changed from new to closed

Replying to pitermach:

That half off topic ramble aside, it does sound like this would be a workable idea since everyone has a different idea for a non-conflicting NVDA key. This will work as long as you don't detect it by windows language, though, since I personally have a US windows here, the only thing that's set to polish is my current country and the keyboard layout.

This can't be done. If we implement this, it will be determined based on the NVDA language (which defaults to the Windows locale). This seems fair enough, as the best we can do here is make things easy for the average novice user.

Since no one appears to be entirely happy with this idea, I'm closing as wontfix. Please reopen if you can make a strong statement of support for the idea as proposed.

comment:18 Changed 2 years ago by jteh

As noted in comment:3, we won't provide a field to customise this, as it can already be done from the shortcut properties dialog. We also aren't changing the default from control+alt+n, as this has been the shortcut for years and is known by too many. If you want it changed for a specific locale, please specify the locale and discuss it with your locale maintainer as well.

comment:19 Changed 2 years ago by jteh

comment:17 deleted by request of commenter for privacy reasons. The text was:

I want sudgest an possible solution for this problem by changing NVDA shortcut key from ctrl+alt+n to ctrl+alt+F5 indipendently by the localization. I suppose that this keys combination should be have no keys conflicts situations because in my experience I didn't ever find keys combinations based on using function keys in congiunction width ctrl+alt keys. I have succesfully tested that Windows allows using this shortcut key. In addition consider that it can be easily remembered because it's similar to shortcut used by Apple on Mac OSX to start Voice Over where F5 function key is used as whell.

comment:20 Changed 6 months ago by grego

Returning to this subject, I noticed last time, that some beginners are forced to uninstall NVDA before giving it a try, because this shortcut conflict with one of our diacritics, although sollution is mentioned in the user guide (who reads the manuals?)...
So, making this shortcut translatable, and changing it for the polish language, would be an acceptable workaround; For most people already using NVDA this change would not be noticeable because of option of keeping existing shortcut to NVDA, and novices would benefit.
About the ctrl+alt+f5, there can be problem with some laptop keyboards, which for example have function keys activated only after pressing it together with fn key, and there can be a problem, that fn+ctrl+alt+f5 could be improperly handled by the keyboard driver.

Having translatable NVDA default key, after updating it respectively in the user manual, would fix the situation.
Somebody mentioned, that it could make some inconsistency with running NVDA, but at the moment, user has to redefine key if he/she wants to use polish letters, which makes it even worse, because nobody knows what keyboard shortcut has been set after installation by the user, and if we're talking about novices, only sollution that somebody finds, can be removing the shortcut permanently, and having no chance of easilly restarting NVDA after hangup.

comment:21 Changed 6 months ago by grego

  • Cc grzezlo@o2.pl added

comment:22 Changed 6 months ago by jteh

See comment:16 for why I closed this. If you (and any other Polish translators) are fine with the proposed solution despite comment:16 and are happy to take responsibility for it (you will almost certainly receive some complaints from some Polish users), I'm happy to make the key translatable.

comment:23 Changed 6 months ago by grego

Yes, I read mentioned comments before, and did it again now...
The problem is, that currently ctrl+alt+n is inacceptable, so anybody has to change it after first installation on his own. It makes a bit inconsistency between installations of NVDA in different places in Poland, and as I mentioned before, it is also a trap for a beginner user, who after NVDA installation loses possibility of writing one of basic polish characters, so decides to uninstall NVDA.
In both cases, such change would make life easier for people installing NVDA for the first time, so I don't hope any complaints from new users...
Existing users most probably are used to keep marked the checkbox "keep existing shortcut" during update, so it'll not change anything for them.
As mentioned before, I'm receiving questions from people about this conflict, that they don't know what to do about it.
I hope, that the altered shortcut key will also appear in the installer's checkbox label, so everybody knows what key shortcut will activate NVDA; also the modification of polish user Guide is trivial - by the way at this moment I added a note from translator about current shortcut conflict and how to handle the situation, but people rarely look into the manual (especially beginners).
Beeing the only active polish NVDA translator for few months, I can take responsibility for this change, also I want to discuss with the polish users community which shortcut key would be most preferred by us, and make appropriate changes in the translation when it'll be possible, if it could happen before 2014.2 it would be great, if not - we of course can wait:).

comment:24 follow-up: Changed 6 months ago by jteh

  • Milestone changed from 2012.2 to next
  • Resolution wontfix deleted
  • Status changed from closed to reopened

I'd rather not do this for 2014.2 because we're already in translation freeze. However, we can do it for 2014.3.

comment:25 in reply to: ↑ 24 Changed 3 months ago by grego

Replying to jteh:
However, we can do it for 2014.3.

GZ: after short discussion on the Polish computer users list, few months ago, the shortcut alt+control+d is non-conflicting and acceptable (my preferred alt+ctrl+v is unfortunately used by Window-eyes for something).
So, i'm impatiently waiting for possibility of changing it on the translator-side.

comment:26 Changed 3 months ago by jteh

  • Owner changed from pvagner to jteh
  • Status changed from reopened to accepted

comment:27 Changed 3 months ago by James Teh <jamie@nvaccess.org>

In 8d689f3f89aacbc6af4ace7562254e1359812136:

It is now possible to change the shortcut key used to start NVDA for locales where the normal shortcut causes problems.

This is done via gettext.
Note that the text for the Create desktop shortcut option in the Install NVDA dialog, as well as the shortcut key in the User Guide, must also be updated.
Re #2209.

comment:28 follow-up: Changed 3 months ago by jteh

Does anyone running from source have time to test this functionality in the t2209 branch with a language other than English? Testing translation stuff, particularly in the installer, is time consuming. :)

comment:29 in reply to: ↑ 28 Changed 3 months ago by grego

Replying to jteh:
GZ: I tested it on the Polish language, and installer works nice with shortcut key other than default (ctrl+alt+d in my case).

comment:30 Changed 3 months ago by James Teh <jamie@nvaccess.org>

  • Resolution set to fixed
  • Status changed from accepted to closed

In cd518b0c32e5776d518da74c4935891fd4703400:

It is now possible to change the shortcut key used to start NVDA for locales where the normal shortcut causes problems.

This is done via gettext.
Note that the text for the Create desktop shortcut option in the Install NVDA dialog, as well as the shortcut key in the User Guide, must also be updated.
Fixes #2209.

comment:31 Changed 3 months ago by jteh

  • Milestone changed from next to 2014.3
Note: See TracTickets for help on using tickets.