Opened 10 months ago

Closed 9 months ago

Last modified 9 months ago

#3726 closed defect (fixed)

Find (NVDA+control+f) Announce Selected Candidate Problem

Reported by: surfer0627 Owned by: jteh
Priority: minor Milestone: 2014.1
Component: Core Version: 2013.3
Keywords: regression Cc:
Operating system: Windows XP Blocked by:
Blocking: #3763
Changes document entry (for developers): Bug Fixes: - When entering Asian input into a control within NVDA itself (e.g. the browse mode Find dialog), "NVDA" is no longer incorrectly reported in place of the candidate. (#3726)

Description

Hello developers,
In browse mode, I press (NVDA+control+f), and then pop up a dialog in which I type some text to find.

I use input method (chinese New Phonetic 2010) to type some text, and press arrow down twice to select candidate.

announce: NVDA and the selected candidate

expected: candidate only

This case occurred in version 2013.3. It is okay in 2013.2.

Thank you.

Change History (8)

comment:1 Changed 10 months ago by surfer0627

To test this case, please change language to zh_TW. This settings allows NVDA to report selected candidate.

Preferences --> General settings...

Thank you.

Last edited 10 months ago by surfer0627 (previous) (diff)

comment:2 Changed 9 months ago by jteh

  • Component changed from Asian character input to Core
  • Keywords regression added
  • Milestone set to next
  • Owner changed from mdcurran to jteh
  • Status changed from new to accepted

Regression caused by changeset:1889cfed.

comment:3 Changed 9 months ago by jteh

  • Changes document entry (for developers) modified (diff)

comment:4 Changed 9 months ago by James Teh <jamie@nvaccess.org>

In 64f4a14463ef7d6ce1eaf6013b4060086c75dca2:

When entering Asian input into a control within NVDA itself (e.g. the browse mode Find dialog), "NVDA" is no longer incorrectly reported in place of the actual candidate.

When determining whether to fudge the name for the NVDA menu, the code wasn't checking whether the saved NVDA menu identity was None before comparing it. This meant that anything with an IAccessibleIdentity of None was getting the name "NVDA" before the NVDA menu was first opened.
Aside from Asian input, this seems to affect message dialogs in wxPython 3.
Re #3726.

comment:5 Changed 9 months ago by James Teh <jamie@nvaccess.org>

  • Status changed from accepted to incubating

In 9ee4bfffd1adb2717a21489a6b7e1a3608828a88:

Merge branch 't3726' into next

Incubates #3726.

comment:6 Changed 9 months ago by jteh

  • Blocking 3763 added

comment:7 Changed 9 months ago by James Teh <jamie@nvaccess.org>

  • Resolution set to fixed
  • Status changed from incubating to closed

In 437343a7e773292991f4005f9e03480a21c7064a:

When entering Asian input into a control within NVDA itself (e.g. the browse mode Find dialog), "NVDA" is no longer incorrectly reported in place of the actual candidate.

When determining whether to fudge the name for the NVDA menu, the code wasn't checking whether the saved NVDA menu identity was None before comparing it. This meant that anything with an IAccessibleIdentity of None was getting the name "NVDA" before the NVDA menu was first opened.
Aside from Asian input, this seems to affect message dialogs in wxPython 3.
Fixes #3726.

comment:8 Changed 9 months ago by jteh

  • Milestone changed from next to 2014.1
Note: See TracTickets for help on using tickets.