Opened 4 weeks ago

Last modified 11 days ago

#4402 incubating defect

while typing passwords speak typed words feature should automatically be disabled

Reported by: blindbhavya Owned by: cannona
Priority: trivial Milestone: next
Component: Speech Version: 2014.2
Keywords: goodForNewDev Cc:
Operating system: Windows 7 Blocked by:
Changes document entry (for developers):


While typing passwords, the typed text is automatically converted into circles/bullets for security reasons.
But supposing my password is nvaccess,nvda
When I type the comma, NVDA says 8 circles pause circle (8 circles represent the number of characters in nvaccess).
This is because I have the speak typed words feature enabled.
However, while typing passwords, this feature should be disabled because in this instance the user is not typing a words.
Hope I was clear.

Attachments (1)

0001-Speak-typed-words-is-disabled-in-protected-edit-fiel.patch (1.1 KB) - added by cannona 12 days ago.
Patch 1.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 4 weeks ago by jteh

  • Priority changed from minor to trivial

comment:2 Changed 11 days ago by jteh

  • Keywords goodForNewDev needsCodeReview added
  • Owner set to cannona
  • Status changed from new to assigned

comment:3 Changed 11 days ago by jteh

  • Keywords needsCodeReview removed
  • Milestone set to next

Thanks! Nicely done. :)

comment:4 Changed 11 days ago by James Teh <>

In cc36379fcbbc6016f3891fd23f03fecd792cddb0:

In password entry fields with speaking of typed words enabled, multiple asterisks are no longer pointlessly reported when beginning new words.

Re #4402.

comment:5 Changed 11 days ago by James Teh <>

  • Status changed from assigned to incubating

In 167df22f91172f3ce98d4dccfd83353b8d95a9d6:

Merge branch 't4402' into next

Incubates #4402.

Note: See TracTickets for help on using tickets.