Opened 3 months ago

Closed 3 months ago

#4404 closed defect (wontfix)

H(n) tag announced twice when nested span given display block

Reported by: haltersweb Owned by:
Priority: minor Milestone:
Component: Core Version: 2013.3
Keywords: Cc:
Operating system: Windows 7 Blocked by:
Blocking:
Changes document entry (for developers):

Description

If an H(n) tag contains one or more span tags that are styled as display: block the H tag is reannounced for every "chunk" of content.

I.e.

<h3>This is a <span style="display: block">nice heading</span></h3>

will read:

"Heading level 3 This is a"
"Heading level 3 nice heading"

Giving the listener the impression that there is more than one H3.

this doesn't happen if the spans are left as (default) inline or given inline-block.

Change History (1)

comment:1 Changed 3 months ago by jteh

  • Resolution set to wontfix
  • Status changed from new to closed

This is by design. A heading is usually only one line, so to avoid pointless verbosity, we don't report exiting a heading when moving by line. However, the downside of this is that we have to report the fact that something is a heading on every line. Otherwise, the user wouldn't know they were still within a heading. A user can check this by moving by character or word, in which case NVDA will report when exiting headings.

Note: See TracTickets for help on using tickets.