Opened 4 years ago

Closed 4 years ago

#748 closed defect (fixed)

Unable to move thru the pdf documents in Adobe reader 9.3

Reported by: mario.percinic Owned by: jteh
Priority: major Milestone: 2010.2
Component: Core Version: master
Keywords: Acrobat reader, unable to read, snapshot 3595 Cc:
Operating system: Windows 7 Blocked by:
Blocking:
Changes document entry (for developers):

Description

If i open any kind of pdf documents with english version of adobe reader 9.3 and last snapshot version which is 3595, nvda doesn't allow me to use the cursor keys to go thru the documents. Even when i try to use continues reading with caps+down errow, the reading is slow and sluggish. Every time when i press the cursor key, error sound is played. I uninstalled and delete all the settings files from nvda and reinstalled nvda with fresh install, and it didn't help. See the attached log file, where you can see the errors pointing to the acrobat scripts.

Attachments (1)

nvda-3595.log (10.9 KB) - added by mario.percinic 4 years ago.

Download all attachments as: .zip

Change History (4)

Changed 4 years ago by mario.percinic

comment:1 Changed 4 years ago by jteh

  • Priority changed from critical to major

comment:2 Changed 4 years ago by jteh

  • Owner set to jteh
  • Status changed from new to accepted

I'm not sure about the sluggishness with say all. I can't reproduce this here. It may be related to the specific pdf you are reading.

As for the errors when pressing cursor keys, I'm guessing you have "Automatic focus mode for caret movement" enabled in Virtual Buffer settings?

Technical info: The problem is that focusableNVDAObjectAtStart returns None, which then gets passed to shouldPassThrough() without checking.

comment:3 Changed 4 years ago by jteh

  • Resolution set to fixed
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.